Home Telegram Scroll Top

简简单单让Copilot Chat用上GPT-4!

我写博文向来简单,直入主题。

相信不少朋友都有Copilot,在VSCode中是可以同时使用Copilot Chat和GPT聊天的,默认是自动3.5/4模型切换的。
现在我的这篇文章教你如何强制全部聊天都走GPT-4模型。10刀的Copilot价值陡增!
经过一众网友和我亲自测试真的会生效!

先看看我的这篇博文,看看如何来白嫖吧。

最简单的方法:

  • 安装 CoCopilot的VSCode插件。
  • 安装完成选择菜单:查看 -> 命令面板 后输入 Enable Copilot Chat (GPT-4) 回车确认。
  • 按提示重新加载VSCode即可。
  • 给个5星好评支持一下。

手动方法:

  • 打开用户设置文件 settings.json
  • 添加配置
"github.copilot.advanced": {
    "debug.overrideChatEngine": "gpt-4"
}
  • 如果已有配置,则合并。
  • 重启VSCode即可。

可以看看效果,证明确实是GPT-4。大家在使用中自行体会吧。
你们无需用这个测,它系统提示里限制了回答编程外的问题。我手动去除限制只为测试GPT-4是否生效。证明生效即可,你们自己问编程问题去感受吧。

分享本文到:

22 评论

留下评论

您的电子邮箱地址不会被公开。 必填项已用*标注


  1. 大佬,请问插件运行需要访问哪些IP或域名?现在个人网络能正常使用,公司网络不行,提示Extension activation failed: “read ECONNRESET”。公司现在是白名单机制。

        • 我的测试:
          在C:\Users\xxx\AppData\Roaming\JetBrains\IntelliJIdeaxxx.xx\plugins\github-copilot-intellij\lib中找到core.jar,
          修改copilot/copilot.properties,
          添加一行:copilot.chat.debug.overrideChatEngine=gpt-4保存即可
          我自己测试的问题是:Kotlin的最新版本是?
          更改后回答有变化
          如果有同样测试结果的麻烦回复下*

          • 我用mac试过了 也是可以的路径是这个 /Users/xxx/Library/Application Support/JetBrains/IntelliJIdea2023.3/plugins/github-copilot-intellij/lib

          • 我做了同样的测试,但我更改之前询问“Kotlin的最新版本是?”,他回答2022.x,等我更改为gpt-4之后,它反而回答2021.x了。
            gpt的数据反而落后了?